Start a new topic

Firmware Update and Reset


After having several strange issues with my Leapfrog Creatr Dual, my printer suddenly started loosing his location during the print. This happened several times with different setting, so I eventually had to stop every print.

I was told that the firmware needs to be reset or updated in order to fix this.

Does anyone know how to do that and which software to use exactly? I tried to find something on this homepage, but I seems that everything was removed. I also tried to find alternative instructions and software on other sites, but they all lead me back here eventually, where I got the message that the page does not exist any more.

I am really desperate right now, can anybody help me please?

Thank you very much,


(2.41 MB)
(3.32 MB)

1 person has this problem

It seems unlikely that a firmware problem would cause this.

Make sure that the set screws (grub screws) on the pulleys on the X and Y axis stepper motors are tight.

Also check that the clamps on the Y axis belts are tight.

Home the print head and then see if you it you can move it with your hand. It should be difficult to move.

Then disable the motors and make sure the print head moves easily. You may need to clean and oil the bearing rods.

To update the firmware you need to get the latest version from Leapfrog by putting in a support ticket. (The version of firmware depends on your specific build.)

The instructions for uploading the firmware are in the User Manual. There are links to the manual on the index page of this forum.

A couple more thoughts:

A loose wire or bad end stop switch could cause this problem (The little switches that are used to home the print head.) These switches are normally "closed" so a loose connection or bad switch will cause the printer to lose it's place. It will also generate an end stop hit error in the log file of the host software but if you have verbose mode turned on (the default) it will scroll of the top of the screen before you see it. Copy and paste the log into notepad so that you can look for errors, or turn off verbose mode so that only errors are shown on the screen. 

A loose stepper motor wire might cause this also.

Print a large hollow cylinder and start moving the wires while it's printing to see if you can make the problem happen.


Thank you very much!

All the screws are tight and I experienced just what you said when I tried to move the Print head.

I already got the Firmware and finished my first print, which was really ok.

However, I experienced something strange after the print was finished. I could not control the movement in the X-axis any more. The print head would only move to the right side, but not back again. The other axis seem to work fine. The same Thing occurs when I stop midprint. As soon as I reconnect the Printer, everything is fine again,.

What could be the reason for this?

I will also try to find out, if the wires caused a Problem.

If that is the reason, how can it be fixed?

Thank you so much for your help!


If you have the left extruder selected you will see the problem with the print head not being able to be moved to the left.
It is a known bug.

As far as the possible wire issue, you may be able to solder the loose wire. Otherwise you would need to get a replacement cable from Leapfrog.


Ok, so does that mean, that the print will continue without Troubles after pausing it? Because I would like to print something very large and I will definitely have to Change the Filament. Or is it better if I fill both Extruders and activate the second as soon as the first runs out of Filament?

The bug is only with the x-axis jog control when the left extruder is selected as far as I know. As long as you don't use the jog controls while the left extruder is selected I would think you would be ok, (I haven't tested that however.)


Ok, thank you!

I will report as soon as I get (or don't get) results...

I started printing yesterday and everything seemed to be ok so far, although the printer lost the y-postition again, but only during the first layer.

During the second layer, the filament did not stick on the first layer correctly, but since there was a knot in the material, I supposed that this caused the tensions. Or could there be another reason for this? I had the same problem with a completely different filament and different settings, but there was also a knot in it.

Furthermore the surface got 'bubbles'. I experienced that on a few other prints before, also with different settings and filaments (btw I use PLA). I used to think that the filament might have been wet, but since it occured with different new filaments...

I continued the print nontheless, since it seemend to get better after five layers or so, but during the nighttime, the print suddenly broke from the bed. At some point the filament appearently stopped flowing, and the printer continued empty. Furthermore it appeared that the support material was only generated after about six or seven layers. Is this a slicing mistake?
I did not think all of this this would be a serious problem, but then I discovered that I lost control over all the axis. It is not even possible to send the printer back to the home position.
What shall I do now? Shall I upload the firmware again? Or is there something seriously damaged?

Thank you,


From the images, I would say that the temperature is too low. Here's my suggestion...
- Start with a simple calibration print, such as
- Print with a HIGH temperature (See the temperature range of the filament)
- If there are no "strings" then the temperature is fine. You can lower 5 degrees and try again.
- If there are "strings" then the temperature is too low. Raise the temperature by 5 degrees and try again.


Hi Jeff!

Thank you for your reply and sorry for my late answer!

I already tried to print with different Settings, but it seemed, that the printer head was not stable. It seemed that it somehow slipped, if that is the correct word.

Leapfrog replaced the Motherboard of my Printer, so maybe that was part of the Problem. So far I can not say much about that, because I have not been able to test the new Motherboard yet. But to be honest, I am not sure, if that was really the Problem..,.

However, I will definitely try your Suggestion and Report as soon as I get results.

Thank you for your help!


were you able to test the new motherboard, I have similar problem with my HS now


Do you want an honest answer? Well... I am about to return the Printer to my reseller. Since more and more Troubles appeared, theyargeed to take the Printer back and give me a different model in return.

But to answer your quesion: The Motherboard helped a Little, but not a lot. Eventually I could regain control of the y- and z-axis, but the x-axis never worked correctly again. The Quality of the prints did not get better as well. Do you have Pictures or videos of the prints? They might be helpful!

Sorry, that I can not help you more!

Best wishes and good luck with the Printer - You will Need it!

Dear Alexandra,

actually I solved the problem , it was exactly the X axis grab holder problem. (for my problem )

for video :

I heard that creatr was very problematic, since the extruder completely changed seems problems "changed" not disappeared. 

I can not recommend you to purchase creatr hs because it has other design issues (for example new fan design under the extruders is very very bad idea. It melts after first print ).

Login or Signup to post a comment

User Manual

Simplify 3D
Creater by Materialise

Quick Start Guide

Filament Setting Guide

Demo Print Downloads

Drivers Downloads

Software Downloads

Firmware Downloads

Software Video Library